Back to overview
Resolved
Latency for Solana chain deposits and withdrawals
Jul 18, 2026 at 12:43am UTC
Affected services
unifold.io
Resolved
Jul 18, 2026 at 12:43am UTC
We are currently seeing elevated fill times for transactions to and from Solana. Deposits involving Solana may take longer than usual to complete.
Funds are safe: transactions will complete once processed, and any delayed transactions will be delivered automatically.
Affected services